Friday, October 23, 2009

PPPoE PPPoEoFR PPPoFR PPPoA PPPoEoA MFR MLPPP MLPPPoFR MLPPPoA

PPPoEoFR not supported on Cisco. Found one reference in 2000 Networkers slide saying it'll pe supported in DSL Phase2 which never happened I guess till 2009!

Plain PPPoFR is supported.

Similarly on ATM,

PPPoA is supported.

PPPoEoA (PPPoE over ATM) is also supported.

MLPPPoA and MLPPPoFR are supported.

---

PPPoE


 

Server Config 

  

Client Config 

define BBA group and attach Virtual-template 

 

  

bba-group pppoe BBA_GRP_PPPoE_SERVER

 

interface FastEthernet0/0 

virtual-template 1  

 

no ip address 

! 

 

duplex auto 

create loopback for Virtual-template addressing 

 

speed auto 

interface Loopback1 

 

pppoe enable 

ip address 1.1.1.1 255.255.255.255 

 

"pppoe-client" dial-pool-number 1

! 

 

no clns route-cache 

enable PPPoE on WAN interface 

 

! 

interface FastEthernet0/0 

 

! 

ip address 10.1.1.1 255.255.255.252 

 

interface Dialer0 

duplex auto 

 

ip address negotiated 

speed auto 

 

dialer persistent à this is needed if no dialer list is being used. This means
interface can be brought up without interesting traffic

pppoe enable group BBA_GRP_PPPoE_SERVER 

 

option2: ip addr dhcp or ip addr x y 

no clns route-cache 

 

ip mtu 1492 

! 

 

encapsulation ppp 

Virtual-Access "member" interface is cloned from the Virtual-Template interface when the PPP connection comes up. Therefore the Virtual-Template interface itself will always be in the down/down state.

 

dialer pool 1

interface Virtual-Template1  

 

ppp ipcp route default -> if Server should provide a default route

ip unnumbered Loopback1 

 

ppp chap hostname CLIENT1
ppp chap password *****


peer default ip address pool POOL_PPPoE
-> not needed if DHCP is used to provide IP or if Static IP is used on the Client side

 

or ppp eap ident CLIENT1
ppp eap password ****

ppp authentication chap
user CLIENT1 pass ****
user CLIENT1 priv 0

 

! 

or ppp authentication eap
ppp eap local

 

  

  

 

  

! 

 

  

ip local pool POOL_PPPoE 10.1.1.2 

 

  

  

 

  

if DHCP has to be used 

 

  

ip dhcp pool CE1 

 

  

network 12.12.12.0 255.255.255.0

 

  

  

  

  


 


 

---------

PPPoFR


 

PPP can be configured either on physical interface or p2p PVC.


 

Dialer interfaces can't be used !! (Dialer can be used in PPPoE and ATM)


 


 

R1-Server:

interface Serial1/0

no ip address

encapsulation frame-relay

!

interface Serial1/0.102 point-to-point

no ip addr

frame-relay interface-dlci 102 ppp Virtual-Template2


 

interface Virtual-Template2

ip address 11.1.1.1 255.255.255.252 or ip unnumbered

no peer default ip address

or peer default ip addr pool <POOL_PPPoFR>


 

R2-Client:

interface Serial1/0

no ip address

encapsulation frame-relay

frame-relay interface-dlci 201 ppp Virtual-Template1

no frame-relay inverse-arp

!

interface Virtual-Template1

ip address 11.1.1.2 255.255.255.252

or ip addr negotiated


 


 

---------

Multilink PPPoFR


 

R1-Server:

interface Multilink1


ip address 11.1.1.1 255.255.255.252 ----à ip is defined on Multilink interface

ppp multilink

ppp multilink group 1 --à
VT and multilink interfaces are tied together with multilink group #

!

interface Serial1/0

no ip address

encapsulation frame-relay

frame-relay traffic-shaping
---à must enable this else error -
%FR-3-MLPOFR_ERROR: MLPoFR not configured properly on Link Virtual-Access1 Bundle Multilink1 :Frame Relay traffic shaping must be enabled

Frame Relay traffic shaping must be enabled for MLPoFR PVCs on the Frame Relay router.

http://www.cisco.com/en/US/tech/tk1077/technologies_tech_note09186a00800b6098.shtml

!

interface Serial1/0.102 point-to-point

frame-relay interface-dlci 102 ppp Virtual-Template2

!

interface Serial1/0.112 point-to-point

frame-relay interface-dlci 112 ppp Virtual-Template2 --à
both PVC will point to the same VT interf

!

interface Virtual-Template2

ip unnumbered Loopback1 -> no ip assigned to VT or unnumbered loopback

no peer default ip address


ppp multilink

ppp multilink group 1

!


 

R2-Client:

interface Multilink1

ip address 11.1.1.2 255.255.255.252 (or ip addr negotiated)


ppp multilink

ppp multilink group 1

!

interface FastEthernet0/0


 

interface Serial1/0

no ip address

encapsulation frame-relay

frame-relay traffic-shaping

frame-relay interface-dlci 201 ppp Virtual-Template1

no frame-relay inverse-arp

frame-relay lmi-type ansi

!

interface Serial1/1

no ip address

frame-relay traffic-shaping

encapsulation frame-relay


frame-relay interface-dlci 212 ppp Virtual-Template1

!

interface Virtual-Template1

no ip address


ppp multilink

ppp multilink group 1


 


 

--------------------

PPPoA

(this is different than PPPoE over ATM; this is plain PPPoA)


 

Method 1: using Virtual-Template


 

interface ATM1/0.809 multipoint

no atm enable-ilmi-trap

pvc 0/809


encapsulation aal5snap

protocol ppp Virtual-Template1


 

interface Virtual-Template2

ip address unnumbered loopback0

no peer default ip address

or peer default ip addr pool <POOL_PPPoA>


 

Method 2: using Dialers


 

interface ATM1/0.789 multipoint

no atm enable-ilmi-trap

pvc 0/708

encapsulation aal5snap


protocol ppp dialer

dialer pool-member 8

!


 

interface Dialer8

ip unnumbered Loopback789

encapsulation ppp

dialer pool 8

dialer-group 1    

peer default ip address pool R8

no clns route-cache

!

ip local pool R8 10.1.1.8


 

!

dialer-list 1 protocol ip permit


 


 

---------------------------------

Multilink PPPoA

Similar to Multilink PPPoFR


 

http://www.cisco.com/en/US/tech/tk1077/technologies_tech_note09186a00800b6098.shtml

int s1/0.1 p

pvc 0/100

encap aal5snap

protocol ppp virtual-temp 1


 

int s2/0.1 p

pvc 0/200

encap aal5snap

protocol ppp virtual-tem 1


 

int virtual-temp 1

multilink ppp

[ multilink ppp interleave]

[multilink ppp fragment 10]

ip uunum lo0

multilink-group 1


 

int mul1

ip addr 200.1.1.1

etc.

---------

Plain Multilink PPP on Serial

int multilink1

ip address 132.32.34.4 255.255.255.0


ppp multilink
à by default added by IOS

multilink-group 1
à by default added by IOS


 

int s1/1

encap ppp

ppp multilink-group 1


 

int s2/1

encap ppp

ppp multilink-group 1

---------


 


 

Multilink FR Interfaces using MFR interface


 

R1 and R2 connected back to back via redundant links

R1-S1/1 ------ßà---- S1/1-R2

R1-S2/0 --- ßà---S2/0-R2


 

On R1

interface Serial1/1

no ip address

encapsulation frame-relay MFR1

serial restart-delay 0

no dce-terminal-timing-enable

no arp frame-relay

!

!

interface Serial2/0

no ip address

encapsulation frame-relay MFR1

serial restart-delay 0

no dce-terminal-timing-enable

no arp frame-relay


 


 

interface MFR1

no ip address

!

interface MFR1.1 point-to-point

ip address 192.168.100.1 255.255.255.252

frame-relay interface-dlci 122

!

interface MFR1.2 point-to-point

ip address 192.168.200.1 255.255.255.252

frame-relay interface-dlci 123


 


 

On R2


 

interface MFR1

no ip address

no frame-relay inverse-arp

frame-relay intf-type dce

!

interface MFR1.1 point-to-point

ip address 192.168.100.2 255.255.255.252

frame-relay interface-dlci 122

!

interface MFR1.2 point-to-point

ip address 192.168.200.2 255.255.255.252

frame-relay interface-dlci 123

!

interface Serial1/1

no ip address

encapsulation frame-relay MFR1

serial restart-delay 0

no dce-terminal-timing-enable

no arp frame-relay

!

!

interface Serial2/0

no ip address

encapsulation frame-relay MFR1

serial restart-delay 0

no dce-terminal-timing-enable

no arp frame-relay

!


 


 


 

No comments:

Post a Comment